Symptom
IPS Sync job failed with an error: You have entered an invalid email address [Email address] Please check your entry."
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.
Environment
SAP SuccessFactors HCM suite 2105
SuccessFactors People Analytics
Embedded Usage of SAP Analytics Cloud
Reproducing the Issue
1. Log in to IPS System
2. Click on Source and select Successfactors Source System
3. Click on Job tab
4. Select Run Now for Read Jobs
IPS Sync failed with an error of:
error=org.apache.camel.http.common.HttpOperationFailedException: HTTP operation failed invoking with statusCode: 400, Response: {"status":400,"message":"User/group operation not completed: You have entered an invalid email address user@sap.com1 Please check your entry."},
Cause
Any email ending with numeric value or two @ symbols is not a valid email.
Example
>Invalid address: email@sap.com1
>Valid: email@sap.com
>Invalid address: email@sap.com@sap.com2
>Valid: email@sap.com
Email addresses with double dot in the domain is also invalid
>Invalid address: email@sap.test.cm
>Valid: email@sap-test.com
Resolution
Avoid using email addresses with double dot on its domain and remove the numeric character added at the end of user's email address in Successfactors system through User data file or Employee Export
See Also
Keywords
Invalid Email address, IPS sync, IPS sync failed , KBA , LOD-SF-ANA-SAC-ADM , SF Admin configurations (Security Center, Provisioning) , Problem