SAP Knowledge Base Article - Public

3095018 - Learning History Connector Exception

Symptom

  • Learning History Connector returns 6035 exception with message "Scheduled Offering item details doesn't match with provided item details".
  • Learning History Connector returns 6038 exception with message "Scheduled Offering start Date is in future" and the Entity ID is different from the class being updated.

Environment

SAP SuccessFactors Learning

Reproducing the Issue

  1. Upload the connector file to the SFTP>
  2. Access Learning Administration>
  3. Go to System Administration> Connectors> Learning History Connector>
  4. Schedule the connector to run>
  5. After the connector runs, click View Results> View Details>
  6. The exception is displayed.

Cause

This is because the Class ID of the affected Class entity is duplicate with another Class's Legacy ID.

Learning History Connector processes SCHD_ID column according to the below logic:

  1. Search for the value as Legacy ID first >
  2. If no result fetched in step 1, then search for the value as Class ID.

Therefore, when a class is created by class connector, Legacy ID should always contain at least one alphabetic character.

If class Legacy ID is all numbers and contains no alphabetic character, there is a huge possibility that 6035 or 6038 exception will occur.

Example:

  1. Learning History Connector file is imported to update Class ID 1000 >
  2. On the other hand, there is another Class ID 50 with Legacy ID 1000 >
  3. SCHD_ID in the imported file has value '1000' >
  4. Connector searches for class whose Legacy ID = '1000' and fetched Class ID 50 >
  5. But Class ID 50 is actually not the class customer wanted to import and doesn't match the class info in the imported file >
  6. As a result, a connector exception will be displayed.

Resolution

Legacy ID should always contain at least one alphabetic character to make it differ from any Class ID.

It's highly recommended that customer does not make Legacy ID all numbers.

If the issue already happens and Legacy ID with no alphabetic characters already exists, customer needs to modify the Legacy ID from UI manually.

There is no available feature to batch modify Legacy ID, customer needs to contact SAP Professional Services to run a script.

See Also

2149831 - SAP Professional Services / SAP Certified Partner / SAP Account Management Team [SuccessFactors Cloud]

Keywords

Success Factors, Learning, Custom Column 99, COL_NUM_99, Scheduled Offering ID, connector, history, exception, 6035, 6038, class , KBA , LOD-SF-LMS-CON , Connectors , Problem

Product

SAP SuccessFactors Learning all versions