SAP Knowledge Base Article - Public

3095018 - 6035 Exception "Scheduled Offering item details doesn't match with provided item details. " occurs in Learning History connector

Symptom

When customer imports data by Learning History connector, 6035 Exception "Scheduled Offering item details doesn't match with provided item details. " occurs.

Import fails.

Environment

SF LMS

Successfactors Learning

Reproducing the Issue

1. Upload csv file to SFTP

2. Run learning history connector, completed with error

3. Click "View Results" > Click "View Details"

6035 Exception "Scheduled Offering item details doesn't match with provided item details. "  is displayed

Cause

This is because the Class ID of the affected Class entity is duplicate with another Class's Legacy ID.


Learning History Connector proceeds SCHD_ID column according to the below logic:

1. Search for the value as Legacy ID first

2. If no result fetched in step1, then search for the value as Class ID


Therefore, when customer is creating class by class connector, Legacy ID should always contain at least one alphabetic character.

If customer's class Legacy ID is all number and contains no alphabetic character, there is a huge possibility that 6035 exception will occur.


For instance, Customer want to import learning history of Class ID 1000.

On the other hand, there is another Class ID 50 with Legacy ID 1000.

SCHD_ID in the imported file has value '1000'.

Connector searches for class whose Legacy ID = '1000' and fetched Class ID 50.

But Class ID 50 is actually not the class customer wanted to import and doesn't match the class info in the imported file.

As a result, 6035 Exception "Scheduled Offering item details doesn't match with provided item details. "  is displayed.

Resolution

Legacy ID should always contain at least one alphabetic character to make it differ from any Class ID.

It's highly recommended that customer should not make Legacy ID all number.


If the issue already happens and Legacy ID with no alphabetic character already exists, customer needs to modify the Legacy ID from UI manually.

There is no available feature to batch modify Legacy ID, customer needs to contact Professional Service to run script.

Keywords

Success Factors, Learning, Custom Column 99, COL_NUM_99, Schedule Offering ID , KBA , LOD-SF-LMS-CON , Connectors , Problem

Product

SAP SuccessFactors Learning all versions