Symptom
You notice that, when trying to create an e-mail workflow rule, the error message XXX is not a valid email address is displayed, after adding an e-mail address, although you have maintained the activity Address Checks, in Business Configuration work center, to allow the saving of inconsistent addresses.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Administrator work center.
- Navigate to Workflow Rules view.
- Click to create a new rule.
- Fill in the details required by the rule.
- Add your e-mail address.
- See the error message.
Cause
The configuration set in the activity Address Checks, in the Business Configuration work center, is not applicable for workflow rules.
Resolution
This is the system expected behavior.
Keywords
Email, E-mail, Workflow, Workflow Rule, Rule, Address, is not a valid email address, Valid, Valid E-mail Address, Error, Error Message, C4C, Service, , KBA , LOD-CRM-WKF , Workflow , How To