Symptom
Field value of "number of days" in sales phase of an opportunity is reset to blank.
Environment
SAP Cloud for Customer
Reproducing the Issue
Prerequisite: Configuration of sales cycle and sales phase for opportunity is existing and there is an existing opportunity, with open status and progress stalled.
- Go to Sales Work Center.
- Go to Opportunityies work center view.
- Search and open an opportunity with status "open".
- Opened opportunity has following status
- Progress status = Stalled.
- Sales Phase= 1-Not yet met.
- Days in sales phase =XYZ days(where XYZ represents number of days).
- Edit opportunity.
- Go to Activities facet.
- Create New Task and Save.
- Refresh opportunity and you observe :-
- Progress status = on Track (changed from Stalled).
- Sales Phase= 1-Not yet met (same as before task creation).
- Days in sales phase = Blank (XYZ days reset to blank).
- Observe the number of days in sales phase is reset.
Cause
In opportunity, value of field “Days in Sales Phase” in opportunity is reset to blank or zero if
- Sales phase of the opportunity is changed.
- New activity/Task is created or assigned to the opportunity.
Resolution
Value of field “Days in Sales Phase” in opportunity is reset to blank or zero.
Keywords
Number Of Days, field Opportunity, Blank, Zero, Updated , KBA , 2108, number of days, field opportunity, , LOD-CRM-OPP , Opportunity Management , Problem
Product
SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2108