Symptom
You are trying to build one Integration Center interface for Intelligent Service Center with the entity CalibrationSessionParticipantsInfo and the browser screen is getting frozen.
Environment
- SAP SuccessFactors HXM Suite
- Integration center
Cause
Our SF engineering colleagues found a strange behavior from the starting entity (CalibrationSessionParticipantsInfo) used in the integration center.
The corresponding API is not respecting $top expression in the query which is resulting in all the records being queried ( ~sample 1000000 records - depends of your entity) on the UI .
This is resulting in the huge delay and hence the screen is getting stuck .
Ideally the API should support $top in which only 25 records will be loaded by default and we will not have problem.
Resolution
As workaround, please follow the below steps :
- Navigate to Advanced Filter page and apply a filter on sessionID (for one record)
- Navigate back to Field configuration page and complete mapping.
- Then remove the filter and save the integration.
Since this is an Event Based integration, it wont be a problem during runtime as filters will be part of the event itself.
Note 01: Every-time the integration needs to be edited, a filter has to be applied first and then the mapping has to be changed. Filter needs to be removed and saved then.
Note 02: For permanent solution, we are contacting the respective module team internally to get this API corrected to support $top expression. We don't have the ETA yet.
Keywords
CalibrationSessionParticipantsInfo, ISC, IC, Integration center, Intelligent Service Center, browser frozen, getting stuck, cannot load, entity, OData, ISE , KBA , LOD-SF-INT-INC-ISE , Integration Center from ISC Events , LOD-SF-INT , Integrations , LOD-SF-INT-INC , Integration Center , LOD-SF-CAL-API , Webservices, OData APIs , Problem