SAP Knowledge Base Article - Public

3096420 - Workflow Email Sent to Wrong User

Symptom

You have setup a Workflow Rule to send an e-mail to the Agent of a Ticket (for example) but it is also sending the e-mail to another User.

Environment

SAP Cloud for Customer

Reproducing the Issue

On our example scenario, let's say we have a Workflow Rule to send an e-mail to the Agent of Ticket 123 (123 represents the Ticket ID).

The Agent of the Ticket is Employee ID ABC (ABC represents the Employee ID) but you notice that there is also an e-mail sent to Employee XYZ (XYZ represents the ID of the second employee).

Cause

Employee XYZ is set as Employee's ABC Delegate.

Resolution

You can either remove the Delegate or set the Workflow Rules to ignore Delegates.

To make the Workflow Rules ignore Delegates:

  1. Go to the Administrator work center.
  2. Select the Workflow Rules view.
  3. Click on More.
  4. Workflow Settings.
  5. Here uncheck the box for Recipient Determination:
    • Determine the active delegates for an employee in the system, as a recipient in Workflow Rules.

To remove the Delegate:

  1. Go to the Administrator work center.
  2. Select the Delegates view.
  3. Find the line for Employee ABC and XYZ.
  4. Under Actions, click on End Delegate Assignment.

See Also

2943939 - How To Configure Workflow To Send E-Mails To Delegate Of The Recipient

Keywords

Recipient ; Custom Recipient ; Notification ; Agent Responsible for Ticket , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications all versions