SAP Knowledge Base Article - Public

3096574 - Revenue Recognition Run Realizes Total invoice Amount of Customer Contract Item Before Its End Date

Symptom

  • You create a fix-price customer contract item and assign a straight-line accrual method to have its total net value/ invoiced revenue realized evenly during its life time. 
  • The customer contract item has been fully invoiced and the end date is reached. 
  • You execute the revenue recognition run in a period before the item's end date and notice that the run realized the total net value already. 
  • No further revenue is realized in the next accounting periods of the item's life time. 

Environment

 SAP Business ByDesign

Reproducing the Issue

  1. In the Cost and Revenue work center go to the Sales Document Items view.
  2. Select Customer Contract items and find item ABC-XX (ABC-XX represents the customer contract item ID). valid from 01.03.YYYY to 31.12.YYYY. for example. 
  3. Go to the Dates tab and verify that the item's End Date has been reached, for example 31.12.YYYY, and that the Final Delivery and Invoice Date is set (for example 01.09.YYYY, the latest business transaction date associated with the contract item, usually the posting date of the latests customer invoice). 
  4. Navigate to the Accounting Data tab. 
  5. In the Revenues per period table you notice that the revenue is realized evenly in the period's of the contract's life time. 
  6. But in one period, for example period 010.YYYY, the complete invoiced amount is realised for the item. All deferrals or accruals are cleared. 
  7. You check the revenue recognition application log and notice that the Total Earned Revenue amount equals the total net value/ invoice amount of item ABC-XX. 
  8. When executing the run for the remaining accounting periods, such as 011.YYYY and 012.YYYY no further revenue is realized. 

Cause

Since the last revenue recognition run, the status of contract item ABC-XX got completed: This happens when the fulfillment status of a contract item is set to finished, either manually, for example after cancelling the item or automatically, when the item's end date is reached.

For the Financials application SAP Business ByDesign derives a Final Delivery and Invoice Date (Check the Dates tab as above). This date is derived from the most recent business transaction on the item, here 01.09.YYYY, the posting date of the latest customer invoice).

Once a contract item gets completed (fully delivered, fully invoiced, end date reached) the revenue recognition run realizes its full net book value in the chosen period, even if this period is before the period of its end date.

Example:

Contract Item ABC-XX

  • Start date: 01.03.YYYY
  • End Date: 31.12.YYYY
  • Invoice Date: 01.09.YYYY. 
  • After the end date, 31.12.YYYY is reached, the item's status changes to Completed (or you manually finished the fulfilment status of the item). 
  • You execute the revenue recognition run in a period before the end date, for example 011.YYYY.
  • The run realizes the full item net book value/invoiced amount. 

Resolution

This is the designed system behavior: Once a contract item is completed in Financials it is no longer relevant for revenue recognition. The next revenue recognition run, provided its posting date is on or after the contract item's final delivery or invoice date,  will clear all deferrals and accruals and realize the full invoiced net value of the item.

To prevent this situation

  • ensure that the revenue recognition run is executed in each accounting period in subsequent order.
  • If you finish the fulfillment manually, verify first that the due revenue was correctly realized in all the periods of the contract item's life time.
  • avoid executing the revenue recognition run retrospectively.

Keywords

contract item, realized revenue wrong, total revenue realized in wrong period , KBA , SRD-FIN-COR , Cost & Revenue , Problem

Product

SAP Business ByDesign all versions