Symptom
When candidate tries to access the new employee step they receive the following error message;
Failed to send data to SF: The remote server returned an error: (500) Internal Server Error. ServiceApplicationException while creating New User in BizX if ONBOARDING_DEMO_ENVIRONMENT or ONBOARDING_PRE_DAY1_EXPERIENCE is enabledUnable to UpdateUserIdINKMS.
Environment
SAP SuccessFactors Onboarding 1.0
Reproducing the Issue
- The Recruiter sent to the external candidate to Onboarding taking action on: Initiate Onboarding
- The Onboarding Contact received the external candidate and completed the Post Hire Verification Step.
- When the New Hire started the New Employee Step, the candidate can't complete his documents and panels.
Cause
- Onboarding Next Person ID Assigned was reset to a point where it clashes with already existing User ID's in the system.
- There can only be 1 candidate with a specific Onboarding User ID in the system, if a second one is created the system automatically sets it to inactive.
Resolution
- Access the Bizx instance from an Admin user account.
- In the search bar look for "Company System and Logo Settings"
- Hit Control F and search for "Next Person Id Assigned".
- Change this to a new number series that will not clash with User ID's that already exist within the system.
- You can check what has been used by downloading the Employee Export.
- In the Employee Export Filter by User ID Lowest to Highest and look through the file to see which different numbering series have been used.
See Also
Keywords
User ID, Duplicate, Inactive, Next Person UUID, Numbering Series, Internal Server Error , KBA , LOD-SF-OBD , Onboarding , Problem
Product
SAP SuccessFactors Onboarding