SAP Knowledge Base Article - Public

3097740 - Multiple Contacts Assigned to Opportunity

Symptom

You created an opportunity and you notice that multiple contacts were assigned to it, but the expectation is that only the Primary Account should be determined.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Sales work center.
  2. Go to the Opportunities view.
  3. Create new opportunity.
  4. You noticed that multiple contacts are determined to the opportunity. 

Cause

In Business Configuration fine tune activity 'Opportunities' -> 'Maintain Involved Parties' the determination step 10 for 'Contact of Account' party is set to take over all parties.

With this setting the system will determine all contacts assigned in the account to the opportunity.

Resolution

This is the expected system behavior. You can change this setting following the steps below:

  1. Go to the Business Configuration work center.
  2. Go to the Overview view.
  3. Open the activity 'Opportunities'.
  4. Click on 'Maintain Involved Parties'.
  5. Select the party 'Contact of Account'.
  6. Click on 'Maintain Determination'.
  7. In the column 'Take Over' you have the below options which you can chose as per your requirement:
  • All parties - Determines all contacts maintained in the account to the opportunity.

  • Main party, otherwise arbitrary one - Determines the main contact of account to the opportunity. If no 'Main' is maintained, determines a contact maintained in the account randomly to the opportunity.

  • Only main party - Determines the main contact of the account to the opportunity. If no 'Main' is maintained, does not assign contact to the opportunity.

Keywords

Contacts, Opportunity, Parties , KBA , LOD-CRM-OPP , Opportunity Management , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2108