SAP Knowledge Base Article - Public

3098750 - SSO Login Issue On iPad - Load Error

Symptom

When using SSO on iPad you get a blank screen with the information "Load Error".

Environment

SAP Cloud for Customer

Reproducing the Issue

1. Try to log in to the system using your iPad in SSO mode.
2. The screen appears in blank with the error message "Load Error".

Cause

The reason for this is because the Apple has deprecated the UIWebView control that we used to use in the IOS app which supported classic SSO login flow.
Now, we are using WKWebView which has so restrictions regarding this and we use the OAuth2 SSO login flow which is also the login flow recommended by Apple.

Resolution

You need to switch to standard SSO (OAuth2) instead of the classic SSO method.

Keywords

SSO, Classic, Error, Load, app, iPad, IOS , KBA , AP-RC-MOB-IPD , SAP Hybris Cloud for Customer Extended App on iOS , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2105