Symptom
You have set in Security Policies under Mobile App Password Validity the option "Prompt for Password After" to any value (e.g. Never Prompt) and expects that the passcode of the mobile apps will act accordingly (e.g. never prompting for the passcode) while users are using the app.
However, the passcode keeps getting prompted for the end users or don't respect the set timer.
Environment
SAP Cloud For Customer
Reproducing the Issue
- Go to Administrator Workcenter.
- Common Tasks.
- Edit Security Policies.
- Select the desired policy.
- Navigate to Mobile App Password Validity section.
- Set the option for field Prompt for Password After to e.g. "Never Prompt" or any other option there.
- While using the mobile app this doesn't work accordingly.
Cause
The setting is from underlying framework and doesn't work for the SAP Cloud for Customer mobile apps.
Resolution
This feature is not supported in the current release of SAP Cloud for Customer.
An alternative option may be to check the SAP Cloud for Customer Customer Influence to submit an idea:
Keywords
Security Policies; Mobile Passcode; Android; iOS; iPad; iPhone; Offline; Password; , KBA , AP-RC-MOB-AND , SAP Hybris Cloud for Customer Extnd App on Android , How To