Symptom
You find that the "Preceding Opportunity" Field shows not assigned in the Report: Sales Order Volume CRMSLOIB_Q0001.
If the manual reference of the Opportunity was added to the Sales Order (Through the Actions -> Update Manual Reference button). The Preceding Opportunity can not be showed in the report.
If the Sales Order is created through the Actions > Follow Up. The Preceding Opportunity can be showed in the report.
Environment
SAP Business ByDesign
Reproducing the Issue
- Open the Report: Sales Order Volume (CRMSLOIB_Q0001).
- Select Sales Order ABC (where ABC stands for sales order).
- Add the field "Preceding Opportunity".
- You can see the field shows not assigned.
- Open Sales Order ABC.
- Navigate to Document Flow tab.
- You can see the preceding Opportunity is EFG (where EFG stands for opportunity) and the preceding Sales Quote is XYZ (where XYZ stands for sales quote).
Cause
The report you are reviewing is an item based report looking for item details.
The behaviour here is because when a manual reference is added to a document, we do not populate this reference to the item references. We only populate to the header document. When a reference is created out of a backend business process flow, there are dependent references that will be created for the items, but adding a manual reference is different and the current design will not allow for this.
Resolution
Currently the behaviour you are seeing is expected behaviour.
Keywords
Sales Order Volume, Preceding Opportunity, report, Update Manual Reference, follow up, Sales Order, Opportunity; CRMSLOIB_Q0001 , KBA , SRD-CRM-OPP , Opportunities , Problem