Symptom
A workbook uses an OLAP connection configured in CMC to connect to the BW system with authentication type SSO.
SSO between BI platform and BW system has been configured.
When opening/launching the workbook from BI Launchpad in Analysis Office, or directly from AO by connecting to BI platform, the SSO to BW system does not work and the popup to enter user and password is displayed.
Environment
SAP BusinessObjects Analysis, edition for Microsoft Office
Cause
When opening the workbook from BI Launchpad, the launcher does not contain a re-entrance ticket to BW. In AO traces (see SAP note 2129389), the ticket is empty as shown in the example below:
<User>
<Name>username</Name>
<Ticket />
</User>
or
SNC/SSO is not enabled in local SAP GUI landscape (which is used depending on the AO settings as described in SAP KBA 3090746)
Resolution
When opening the workbook from BI Launchpad, the launcher must contain a re-entrance ticket to BW. This can be checked by recording a trace as described in SAP note 2129389 and making sure the ticket is not empty as in the example below:
<User>
<Name>username</Name>
<Ticket />
</User>
If the ticket is empty, please consult the BOE admins to check and make sure there is a trust established between BOE and the BW server.
When the launcher from BIP has no SNC/SSO information, AO copies that information from the local SAP GUI landscape. Therefore, SAP KBA 3090746 can be checked to make sure everything is in place for the SNC/SSO to work in AO.
See Also
3090746 - Central Note: Analysis for Office secure connection
Keywords
sso, re-entry, re-entrance, ticket, logon, credentials, dialog, user, password, asking, popup , KBA , BI-RA-AO-CON , Please use component BI-RA-AO-XLA , BI-RA-AO-XLA , Excel Addin , BI-RA-AO-BIP , AO Precalculation, Scheduling and AO InfoOb... , Problem