SAP Knowledge Base Article - Public

3099382 - Blue screen appearing for dynamically created users

Symptom

Dynamically created users are seeing blue screen after logging into SAC.

Environment

  • SAP Analytics Cloud
  • Custom Identity Provider 

Reproducing the Issue

  1. Configure the SSO SAML and enable the dynamic user creation option  in SAC.
  2. Logon to SAC tenant with the backend user.
  3. A blue screen is appearing (No menu, no buttons are available).

Cause

  • The 'preferredLanguage' attribute set in the custom Identity Provider has an invalid format which SAC does not understand.
  • For instance, the IdP passes 'preferredLanguage' attribute as 'en-US', however the correct attribute for SAC would be 'en'. 

Resolution

Change the 'preferredLanguage' attribute on the custom IdP side to 'en', so the correct value will be passed to SAC.

See Also

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Keywords

idp, custom, saml, sso, roles, blank, not able, can't, preferredLanguage, trace, , KBA , LOD-ANA-AUT , SAC Authentication / Login , Bug Filed

Product

SAP Analytics Cloud all versions