Symptom
Dynamically created users are seeing blue screen after logging into SAC.
Environment
- SAP Analytics Cloud
- Custom Identity Provider
Reproducing the Issue
- Configure the SSO SAML and enable the dynamic user creation option in SAC.
- Logon to SAC tenant with the backend user.
- A blue screen is appearing (No menu, no buttons are available).
Cause
- The 'preferredLanguage' attribute set in the custom Identity Provider has an invalid format which SAC does not understand.
- For instance, the IdP passes 'preferredLanguage' attribute as 'en-US', however the correct attribute for SAC would be 'en'.
Resolution
Change the 'preferredLanguage' attribute on the custom IdP side to 'en', so the correct value will be passed to SAC.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
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Keywords
idp, custom, saml, sso, roles, blank, not able, can't, preferredLanguage, trace, , KBA , LOD-ANA-AUT , SAC Authentication / Login , Bug Filed
Product
SAP Analytics Cloud all versions