SAP Knowledge Base Article - Public

3099546 - BOM Sub Items are not visible in a C4C Contract after the Request External Pricing call

Symptom

You are Requesting External Pricing in a C4C Contract, however it does not show the BOM Sub Items.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Contract Work center.
  2. Search for Contract ID.
  3. Open it.
  4. Go to Items Tab.
  5. Click on Action.
  6. Then on Request External Pricing.

Cause

After the Request External Pricing call, BOM Sub Items will not be transferred or seen in C4C. BOM explosion happens only when the contract is replicated to ERP/S4H system. Once you transfer the Contract from C4C to ERP/S4H, if BOM is configured for one of the items in the On Premise system, then this data will be sent back to C4C.

Resolution

This is expected system behavior.

Keywords

Contract, BOM, Sub Items, Request External Pricing , KBA , LOD-CRM-INT-ERP , Integration of C4C with ERP , How To

Product

SAP Cloud for Customer add-ins all versions