Symptom
- e-Signature step is not being triggered for the candidate.
- e-Signature is missing under the Process Tasks in Manage Data >> Process.
- e sign tile not working
- Document Flows shows '0' in the document ID of the forms
- Signature Status shows 'In Progress'
- Application error in Manage Document Template Mapping
- while trying to invoke the method com.successfactors.documentgeneration.app.MappingTokenMeta.getObjectId() of a null object loaded from local variable 'mBase'
- fingerprint=b7b61ee3c427dcf8260f6c19a15359729608bbb3
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental
Environment
SAP SuccessFactors Onboarding
Reproducing the Issue
- Login as the candidate
- Complete the Personal Data Collection Step
- e-Signature step is not triggered and the tile is not generated.
Cause
Two possible causes:
Cause One:
- Per the Engineering Team, the cause of this issue/error shown in the logs is that the document flow got finished without creating or generating any e-signature tile.
- This happened because of the error happened on PFS side. This is a very rare error which happens sometime if we couldn't get the response from the PrintFormsServiceClient.
- Error logs will have this message: Output Parameters [{formsReadyToBeSigned=null}]
Cause Two:
- One of the candidate's form has a document uploaded with a name that a special character. e.g ".Form_Name".
- Since the form has the delimiter ".", causes the system to unable to understand the document type while saving the generated document.
Cause Three:
- Print Form Service URL is missing /odata/PDF at the end of it in Provisioning
Cause Four:
- PDF document had duplicate field names hence PDF editor added special Char #0 and #1 to differentiate between the two keys
Resolution
Resolution One: Need to restart the Onboarding Process for the candidate so the documents are retriggered and get a new response from the PrintFormsServiceClient.
- Navigate to the Onboarding Dashboard
- Find the affected candidate
- Click View Details to enter the record
- Click Actions on the Right > Restart Onboarding
Resolution Two: To resolve the issue, re-upload the document with a proper name and try the document flow again.
- Navigate to Maintain Onboarding and Offboarding Document Templates
- Click on the Modify Document Template pencil
- Remove the special char from the name of the document > Click update
Resolution three:
- Navigate to Provisioning
- Company Settings
- Under Basic Authentication Credentials
- Enter /odata/PDF at the end of the URL
Resolution four: To resolve the issue, re-upload the document with a proper name and try the document flow again.
- You must download the affected PDF file
- Edit it in PDF editor
- Rename one of the keys
- Ensure there are no other special characters in field names such as "_"
- Save the form > delete the affected one in the system
- Upload your updated form to the system
- Application error should be gone after the changes
Keywords
PrintFormsServiceClient, INC0674165, formsReadyToBeSigned, e-signature, Document Flow, Onboarding, ONB 2.0, OBX,errorId=8f9ba58c-6ea2-4390-905b-aba61cfc675c, fingerprint=b7b61ee3c427dcf8260f6c19a15359729608bbb3, null object loaded from local variable 'mBase', application error, Manage Document Template Mapping , KBA , LOD-SF-OBX-DM , Document Management , Problem