Symptom
When creating an integration using Integration Center and selecting any RCM entity, not all fields from that entity are showing.
Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors Recruiting Management
- SAP SuccessFactors HXM Suite
Reproducing the Issue
- Go to Integration Center
- Select File Output Integration
- Type the entity to create a job (e.g. JobApplication)
- Only one field is visible
Cause
There is a (html) formatting or misconfiguration in one of the fields being used on one of the template for that entity, this causes Integration Center UI to not read all fields
Resolution
The issue usually happens in instruction type field which uses html formatting.
As much as possible, use simple formatting that is supported within the Successfactors UI.
If this formatting can be done using richtext (CKEditor) editor, it should not be an issue when this label is used in Integration Center.
Trying to find which filed is being affected:
- Create a new integration
- Select the affected entity.
- Before moving to the next screen, use your browser's console (f12)
- Move to the next page, preproducing the issue
- Look on the console for the entry(ies) Uncaught
- By expanding that entry you will most likely find which field(s) in that template is (are) the culprit.
- After that, edit that field's description in order to remove unsupported HTML (see info on the top of this resolution section)
Keywords
INT-6472, jobrequisition, candidate, joboffer, cannot create, report, import, export, IC, html, uncaught , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-INT , Integrations , Problem