SAP Knowledge Base Article - Public

3102275 - Custom CDS Views: Associated datasource is not visible while adding a filter

Symptom

In Custom CDS Views app, when you try to add a filter, the associated data source(s) with cardinality [0..*] or [1..*] are not visible.

Environment

SAP S/4HANA CLOUD

Reproducing the Issue

1. Open a custom CDS view in app Custom CDS Views

2. Go to Filter tab, Edit and then try to add a filter

3. In the 'Select: Field for Filter' pop-up, the associated datasource with cardinality [0..*] or [1..*] does not show up

Cause

When [0..*] or [1..*] is used in Association, a field of the associated view (or table) cannot be used in WHERE condition and cannot be added using Extend View either.

Read more explanation in blog: Cardinality of Association in CDS View | SAP Blogs

Resolution

This is an expected behavior as explained above.

Only the views with cardinality [0..1] is visible in the filter Value help for selection.

Keywords

associated data source, conditions, WHERE condition , KBA , BC-SRV-APS-GKE , Generic CDS Key User Editor , Problem

Product

SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions