SAP Knowledge Base Article - Public

3103529 - E-Mail Address Check / Validation C4C

Symptom

The e-mail address validation in Cloud for Customer allows e-mail addresses that you consider not to be complete.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to the Customers work centre
  2. Go to the Accounts, Individual Customers or Contacts view
  3. Open any of these objects.
  4. For example an account.
  5. In the address/ header, enter an incomplete e-mail address such as: wrong@mail  without any dot, nothing after the dot: no '.com'/ '.ie' or wrong@example.com# etc.
  6. Save.

RESULT: the system allows the save - there is no dot-validation.

Cause

The current implementation of the e-Mail check in C4C follows the official RFC5322 which allows for emails with no '.' after the '@' or similar inconsistencies.

Resolution

Any change to this system design can be requested on our influence page:  https://influence.sap.com/sap/ino/#/campaign/1868

Please note that it is not possible for our Support Team to provide you additional information regarding the availability of this feature in a future release.

See Also

Influence Page

Keywords

e-mail address, missing, wrong, dot-validation, RFC5322 , KBA , LOD-CRM-ACC , Account , How To

Product

SAP Cloud for Customer core applications 2108