Symptom
The following error is received when submitting e-verify case in Onboarding
"E-Verify did not receive your case information. Please try to resubmit or try again later by going to the E-Verify To-Do tile, find the new hire and click Start to retrigger the E-Verify case."
Environment
SAP SuccessFactors Onboarding
Cause
Hyphens in phone number submitted such as: ###-###-####
Resolution
When submitting e-verify, two phone numbers are being submitted; one from the employer and one from the employee. First check if the phone format submitted from the employer is correct.
- Admin Centre
- Compliance Settings
- Select US
- Select E-Verify
- E-Verify Configuration
- Edit configuration
- Phone number field must be 10 digits no hyphens
The second phone number submitted is the employee. Review the candidate's number and ensure no hyphen or '+' is added. The number must be 10 digits long. If any character such as '-' or '+' is found remove and attempt to submit case again.
Keywords
SF, success factors, ONB, OBD, on boarding , KBA , LOD-SF-OBX-EVF , Everify , Problem