Symptom
The error "Failed to load data, please try again later" is returned when accessing the Ask HR application through the SuccessFactors mobile app as a given user or as all users in the system.
No errors are observed when accessing Ask HR through the browser.
Environment
SuccessFactors Employee Central
SuccessFactors Employee Central Service Center
Reproducing the Issue
- Access the web application and proxy as the affected user
- Log in to the mobile application and try to access the Employee Central Service Center mobile application.
- The error "Failed to load data. Please, try again later" is returned.
Cause
The error happens for specific users in the system
The affected user(s) cannot access the application due to missing permissions.
Resolution
In addition to the regular permissions required to use Ask HR in any platform, the 'Admin access to MDF Odata API' permission is required for using Ask HR on the mobile app.
This is stated in the following page of the official Employee Central Service Center implementation handbook: Prerequisites - SAP Help Portal
NOTE: The Ask HR development team is working on removing the 'Admin access to MDF OData API' permission as a pre-requisite to use Ask HR on the mobile app. Such change is planned for the b2205 (first half of 2022) or b2211 (second half of 2022) release.
Keywords
employee, central, service center, unable, not, access, askhr, ask, hr, failed, cannot, use, mobile, app , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , Problem