SAP Knowledge Base Article - Public

3104525 - Sales Order is not Pulling Ship-To Address from Account

Symptom

When clicking on the Address Details option from the Ship-To within a Sales Order, you expect to see the Ship-To options maintained under the Addresses subtab of the Communications tab from the Account.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Sales Orders work center.
  2. Select the Sales Orders view.
  3. Search for the ID ABC (ABC represents the ID of the Sales Order).
  4. Click Edit.
  5. Under the General tab, click on the Address Details hyperlink in Ship-to Section.
  6. Click on the value box of the Address field. 

The options which are being presented are not the options maintained under the account.

Cause

The system is not selecting or retrieving the data from the accounts Address subtab, since the Ship-To party is a different business partner and the system will retrieve the data maintained under the Ship-To business partner.

In this example we will use Account XYZ and Ship-To HIJ.

Under the Sales Order ABC, the account being used is Account XYZ and Ship-To HIJ.
When navigating to the Address subtab of the Account XYZ, you see several addresses which you have maintained a Yes for Ship-To.
However, the Ship-To party being used in the Sales Order ABC is HIJ, hence the system will retrieve the addresses information from the business partner HIJ and not from the Account XYZ.

 

Resolution

This is the system expected behavior.

Keywords

Sales Order, Ship-To, Address, Account, Wrong, Value, Business Partner , KBA , SRD-CRM-ORD , Orders & Contracts , How To

Product

SAP Business ByDesign all versions