Symptom
You are trying to perform the migration of a Customer Contract which has Entitlements related to it, however, you are facing the following message: Enter products/services the account is entitled to for this contract item.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to the Business Configuration work center.
- Access the Overview work center view.
- Search and open fine-tuning activity Migration of Customer Contracts.
- Click the link to Migrate customer contracts using the migration tool.
- In the new screen, select file ABC (ABC represents the ID of the file you are using).
- Click the Execute Migration, then select Execute Migration Step by Step.
- Message is displayed in the log for step 3 - Simulate Import
Cause
In the migration template the sub tab Entitled Products for Entitlements is not available.
For entitlements, the Customer Contract expects the list of the products or product categories contained in the entitlement item to which the account is privileged (in the Entitled Products tab of the Customer Contract).
Since the entitled products cannot be included in the migration, the warning message occurs.
Resolution
This is the system expected behavior.
The Customer Contract can still be migrated but the Entitled Product(s) have to be manually maintained in the Customer Contract after the migration is finished.
Keywords
Customer Contract, Migration, Entitlement, Entitled, Products, Services, Account, Item , KBA , AP-CCP , Customer Contract Processing , How To