SAP Knowledge Base Article - Public

3105164 - Export of Customer Addresses doesn't Include External Key for the Main Address

Symptom

You imported customer adresses via data workbench incl. external keys.

But in an export the external keys are not shown for the main address in the file.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. Go to Data Workbench
  2. Go to Export view
  3. Export Customer Addresses 
  4. In the export file, search for the related account
  5. Find for most records Object ID with External_Key and Corporate_Account_ExternalKey
  6. But for the Main Address, find Object ID with Corporate_Account_ExternalKey only, without External_Key

Cause

The main address was created via the customer header because at least one address field of the header is filled. For example, there is a value in the column CountryRegion.
If at least one address field of the header is filled, this will become the main address and you cannot specify an external key for the address implicitly created via the header.

Thus all the main-addresses implicitly created via the header do not have external keys.

Resolution

To avoid this, kindly leave all the address-fields of the header empty and maintain all your addresses via tab Account_Addresses.

Caution: If you have several addresses per customer in tab Account_Addresses you must set one of them as main address via column Main_Address.

Keywords

missing, not available , KBA , LOD-LE-BP-BP , Business Partner , Problem

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2108