SAP Knowledge Base Article - Public

3105245 - Cannot Edit Payment Method for Customer Invoice

Symptom

You want to edit the Payment Method field of a Customer Invoice, however, the field is grayed out.

Environment

SAP Business ByDesign

Reproducing the Issue

  1. Go to the Customer Invoicing work center.
  2. Select the Invoice Documents view.
  3. Search for the document ABC (ABC represents the ID of the Invoice).
  4. Click Edit.
  5. Payment Method field is not available for editing.

Cause

The Payment Method field can only be maintained in two scenarios.

When creating the source document of the Customer Invoice.
For example, when creating the Sales Order document, you have the option to add the Payment Method which will be retrieved to the Invoice.

or

When creating a New Manual Invoice, you have the option to add the Payment Method which will be retrieved to the Invoice.

Resolution

This is the current system behavior.

An alternative option may be to check the SAP Customer Influence Platform and submit an idea.

Keywords

Payment Method, Customer Invoice, Disable, Grayed Out, Cannot Edit , KBA , SRD-CRM-INV , Customer Invoicing , How To

Product

SAP Business ByDesign all versions