SAP Knowledge Base Article - Public

3106886 - Integration Center job triggered by ISC event doesn't pick any record (message "No Records found for integration; processing finished...")

Symptom

An Integration Center job is configured to be triggered by an Intelligent Services event (such as 'Employee Hire'). The job executes, but does not process any record.

When checking the Integration Center execution logs, it has the following message:

"No Records found for integration; processing finished..."

NOTE: Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental.

Environment

  • SAP SuccessFactors HXM Suite
    • Intelligent Services Center (ISC)
    • Integration Center

Reproducing the Issue

  1. On this example, the Employee Hire event is configured to trigger an Integration Center job with timing set as "On Effective Date":



  2. On August 25th, a new employee is inserted into the system, with a hire date of August 30th (in the future):



  3. The event is triggered by Intelligent Services successfully, as expected:



  4. On August 30th (employee's hire date), the Integration Center job is triggered successfully as well, but it doesn't process any records:

Cause

There are three possible causes for this issue:

  1. ISC publisher user has missing permissions in the object related to the ISC event. For example, if the event is "Employee Hire", its object would be Job Info.
  2. The record that was sent to ISC is future-dated at the time the event triggers, or it's a historical record (record from the past). For example:
    • On January 1st, an Employee Hire record is created effective on January 5th.
    • The event in ISC is set to be triggered "When event is published":
    • This makes the event to be triggered on January 1st, the day that the record got created. On this day, it is still a future-dated record, since it will be effective only on January 5th.
  3. There are more records with the same effective date as the record that triggered the ISC event.
    • This is the scenario covered in the example from the "Reproducing the Issue" section above.

Resolution

In order to solve the issue, refer to the actions below which are related to the causes presented previously.

Cause #1: Missing Permissions

Please make sure that the user assigned as publisher of the event in ISC has proper permissions in the object related to the ISC event. For example, on Employee Hire event, make sure that the publisher has all Job Information permissions under the Employee Central Effective Dated Entities category in Manage Permission Roles.

In order to know who is the publisher of the ISC event, go to the ISC event and open the flow that triggers the Integration Center job. The publisher will be shown at the top, as below:

Aanya singh is the publisher user of the event in the screenshot example above.

Cause #2: Future-dated or historical record triggers the ISC event

The issue will occur on this scenario because Integration Center jobs that are triggered by ISC can't retrieve future-dated or historical records, as explained in the KBA 3074096 - Time-based filters are not available in Integration Center jobs connected to ISC events.

This is a limitation of this type of Integration Center job, for workarounds please refer to the KBA mentioned above.

Cause #3: Multiple records with the same effective date behavior

Whenever multiple records are created with the same effective date, a Sequence Number value will be used to identify them. Refer to the Help Portal page Multiple Changes Per Day (MCPD) Entities | SAP Help Portal for more details.

e.g.: When two changes are made for the same effective dated record in a day, effective dated entities maintain two change records with sequence number 1 and 2:

The record with sequence number = 1 is the one containing the Hire data, so it is the one sent to ISC.

But, as explained above in cause #2, future-dated or historical records can't be retrieved by Integration Center jobs triggered by ISC, and in OData API (which is used internally by ISC and IC) the record with sequence number = 1 will be considered as an historical record. Integration Center can only see the current record, which in this case is the record with sequence number = 2. Since it can't see the sequence number = 1 record, the issue occurs.

The issue can be avoided by not inserting multiple records with the same effective date as the event's date (i.e., link the IC job to the latest event, in this case being the job change event, so that the record with the latest (or highest) sequence number would be fetched in the IC job run). 

In other words, link the IC job to the latest event (e.g. a job change event) so that the active record will be fetched in the IC job run.

Should you have a strong business requirement for a more automated solution (e.g. a modification of the entity key filter by removing the sequence number only for Hire Event (MCPD entities)), please submit an Enhancement Request via our Influence channel.

See Also

2948406 - Troubleshooting steps for Intelligent Services Center (ISC) to Integration Center (IC) Issue

Keywords

IC, ISC, missing, employee, data, effective-dated, future, effective, start date, sequencenumber, seqNumber, sequence number, multiple, publisher, permission, rbp , KBA , LOD-SF-INT-INC-ISE , Integration Center from ISC Events , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors HCM Suite all versions

Attachments

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