SAP Knowledge Base Article - Public

3107957 - Unable to create a Cloud Platform Account in a NS2 SAC tenant for use with the Cloud Connector

Symptom

When configuring the Cloud Connector with SAC, one of the early steps in the process is to create a Cloud Platform account. This account is used to authenticate from the Cloud Connector to the SAC tenant running on the Cloud Platform.  To create the account, the documented instructions are to:

  • Log into SAC (user should be assigned to the Admin role) 
  • Navigate to the System > Administration page
  • Under the Data Source Configuration tab, enter your user's email address and click on the 'Add Cloud Platform User' button

When following these steps, a toast message appears: 

"We were not able to add the user account.  Please try again later."

** Note: The correlation ID varies and is unique to the session.

Environment

  • SAP Analytics Cloud (running in a SAP NS2 landscape)

Reproducing the Issue

The toast message shown above can occur after clicking the "Add Cloud Platform User" button in the screenshot below:

Cause

This error has been resolved and should no longer occur (as of SAC release Q4.2022).  By adding an email address to the section above, SAC will automatically assign the appropriate "Cloud Connector Admin" role to your user for this one specific SAC tenant.  If you have multiple SAC tenants provisioned by SAP NS2, each tenant is unique and will need to be setup using the same steps (although the same email address is not required).  It's preferred to use an email address for a user that is already defined in the SAC Users page.  The email you specify will be used inside the Cloud Connector when configuring the new connection.

Resolution

If you do happen to experience the toast message above, Please create a support ticket under the component LOD-ANA-ADM and include the following text to expedite the process.  Refer to this Kbase article in your support ticket.  Be sure your tenant is provisioned by SAP NS2 before submitting as this issue is specific to only SAC tenants running in a SAP NS2 landscape.  All NS2 SAC tenants use the same URL pattern:  *.sapns2.us.

Note to SAP Support:  Please forward this issue to NS2 via the component (XX-SER-SEC-CLD).  

We require a user to be added to the "Cloud Connector Admin" role for the following NS2 SAC tenant (per SAP Note 3107957)

User's Email Address: 

SAC Tenant URL: 

Subaccount: 

If you are unsure what your subaccount is (or if it is not populated inside the "SAP Cloud Platform (SAP CP) Account" section as seen in the screenshot above, the value can also be found by using Chrome DevTools while capturing an SAC user logon.

To do this, open a new Chrome browser or tab.

  1. Enter your SAC tenant url
  2. Before entering your user credentials, Open 'Developer Tools' by either:
    • F12
    • Chrome menu > More Tools > Developer Tools
  3.  Filter on the keyword 'session'
  4.  Login to SAC.  When your user login is accepted and you are presented with the main SAC home page, go back to the Chrome DevTools panel and find the entry for the login session.  It will look similar to the following screenshot.
  5. Copy out the json results
  6. Search for "TENANT_GUID".  The value is your SAC subaccount.

Keywords

NS2 National Security Services CRE SAC SCC BTP , KBA , LOD-ANA-ADM , SAC Administration , LOD-ANA-AQU , Import Data Connections (Acquiring Data) , Known Error

Product

SAP Analytics Cloud 1.0

Attachments

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