Symptom
The report Customer Contract Statistics (CRMCCOHHB) shows any number for 'No. Of Active Contracts' for Contracts which are already expired when zero is expected.
Environment
SAP Business ByDesign.
Reproducing the Issue
- Go to Sales Orders work center.
- Go to Contracts view.
- Search for Contract ABC.
- Click in the Edit button.
You can see that the Contract End Date has already passed and the Validity of the document is Expired.
- Go to Sales Orders work center.
- Go to Reports view.
- Open 'Customer Contract Statistics' report (Technical ID: CRMCCOHHB).
- In View section put the Row Fields 'Contract' and 'Contract End Date'.
You can see that for Contract ABC the No. of Active Contracts is 1, for example, when 0 is expected.
Cause
This behavior is a technical limitation in the system. For these two cases the system doesn't work as expected:
- Contract was canceled on a lesser month as compared to today's month.
- Contract's End Date is at the end of the month. An automated BTM task took a little longer to execute and changed the validity status to expired on a timestamp greater than 12:00 of first day of the next month.
Resolution
There is no solution for these identified cases. The Development Team is working to resolve it in the future releases.
See Also
- SAP Help Portal: Customer Contract Statistics
Keywords
Contracts, End Date, Validity, Expired, Active Contracts, Report , KBA , SRD-CRM-ORD , Orders & Contracts , How To