SAP Knowledge Base Article - Public

3108453 - Upsert using Integration Center is failing - Recruiting Management

Symptom

When running an integration job to upsert data in the system, the job is failing, but when running a preview report of the job, it is successful.

Possible errors seen:

  • templateId required, with the index 0;
  • (user name) is not part of the group: (recruiting group name) with the index 0
  • (field ID) invalid, with the index 0
  • Key value cannot be null.
  • <field ID> is required in template XX

Environment

SAP SuccessFactors Recruiting Management

Reproducing the Issue

  1. Go to Integration Center
  2. Create a new  Scheduled CSV File Input Integration Job
  3. Setup the Configure Filed data mapping and Destination Setting
  4. Import the csv file in the SFTP server
  5. Run the integration job
  6. Review the result and it failed.

Cause

Here we have some possible causes for the issue:

  1. templateId required, with the index 0; ChangeSet index 1 
    There are rows in the file where job requisition id being upserted is not valid.
  2. (user name) is not part of the group: (recruiting group name) with the index 0
    The operator who is assigned in the requisition has been removed from the recruiting group that it linked to the operator field.
  3. (field ID) invalid, with the index 0
    The value being sent in the field may be incorrect.
  4. Key value cannot be null.
    One of the required field is being mapped but the value being upserted is null.
  5. <field ID> is required in template XX
    Application ID that is being updated has required field not answered during application

Resolution

Below we have some possible resolutions for each cause:

  1. Cause 1:
    This requisition ID could be deleted. Generate a new report in Report Center to ensure that they are active requisitions. If you are using Integration Center, use the "Is Deleted" field to filter out deleted requisitions.
  2. Cause 2:
    Update the operator field or add the user back in the recruiting group.
  3. Cause 3:
    If the field is a picklist field, be sure that option ID is in the picklist ID mapped in the field.
  4. Cause 4:
    Review the field mapping and csv file. Check the column where the field is mapped. Be sure that all row values populated.
  5. Cause 5
    The system will not allowing upserting application unless these required fields are satisfied. This can happen in forwarded candidates. The integration user must provide these required fields in the csv file or the recruiter can manually fill the field in application before upserting the application via API or Integration Center.

Keywords

Centre, via, error, failed, employee, recruiter, odata api, JobRequisition, JobApplication, JobOffer, Candidate, CandidateLight, fails, unsuccessful, event , KBA , LOD-SF-RCM-INT , Integration Center & Intelligent Services , LOD-SF-INT , Integrations , Problem

Product

SAP SuccessFactors Recruiting all versions