SAP Knowledge Base Article - Public

3108585 - C4C Deletes Leading Zeroes from S4hana PO Number

Symptom

When adding Leading Zeroes into the PO Number field, C4C removes the leading zeros on save.

Environment

SAP Cloud for Customer

Reproducing the Issue

Prerequisite: The PO Number field is active for Sales Orders in your system

  1. Go to the Sales work center
  2. Go to the Sales Orders work center view
  3. Search and open a relevant sales order where the PO field is available
  4. Click edit
  5. Add leading zeros in the PO Number field, followed by any combination of numbers
  6. Save

Result: the leading zeroes are deleted by the system after save. You expect leading zeroes to be allowed as this is the case in SAP S4hana.

Cause

It is unfortunately not possible to keep the leading zero for the PO number because this would be incompatible change in the standard which lead to data inconsistency for our customers.

Resolution

The options we can suggest is either to avoid using IDs with leading zeros in the S4 or to implement a PDI solution for the leading zero handling.

See Also

Keywords

leading zeroes, zero, vanish, missing, delete, PO number , KBA , LOD-LE-CQP , Customer Quote Processing , Problem

Product

SAP Cloud for Customer core applications 2108