Symptom
In the Candidate Profile, a certain field is filled but when checking the Job Application, the same field is empty even though both field definitions have the same ID on both templates.
Environment
SAP SuccessFactors Recruiting Management
Reproducing the Issue
- Go to the Candidate Profile of the affected candidate
- Confirm the field is filled as expected
- Go to the Job Application affected
- Confirm the same field
Cause
This KBA covers only the following cause:
This happened because at the moment the candidate applied for the Job Requisition, the field was defined in the Candidate Profile XML but not in the Job Application XML, later on, the same field has been defined in the Job Application XML but the sync didn't occur.
Resolution
The sync between the Candidate Profile and Job Application will not occur retroactively. If at the moment the candidate created the Job Application, the same field was not yet defined in the Job Application XML, the sync will not occur if the field is defined later on.
This is an expected behavior.
For existing Job Applications wherein the field is empty, the solution would be filling the field manually, which can be done either by the candidate itself or the recruiter, taking into consideration that one or both have write permission to edit the field affected.
Keywords
KBA , LOD-SF-RCM , Recruiting Management , Problem