SAP Knowledge Base Article - Public

3110455 - Error when trying to open Rehire Verification Tile - Onboarding

Symptom

  • An error is being received when trying to open Rehire Verification Tile.
  • Error Message: while trying to invoke the method java.util.Map.containsKey(java.lang.Object) of a null object loaded from local variable 'fieldVals'
  • The logs show below errors:
    • No data found from RCM for application id : UVXYZ, candidate id : XXXXX, job req id : XXXX
    • Applicant is already hired for Application ID: UVXYZ

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

  1. Login to the instance
  2. Click on the Rehire Verification Tile
  3. The error appears

Cause

  • One of the users in the Rehire Verification Tile is already hired.
  • The application ID for the hired candidate was associated with two different process instance Ids
  • Onboarding was initiated twice for the same user. There are two process triggers for the same application Id UVXYZ.
    • A process id where the candidate is already hired as a rehire.
    • A process id where it is waiting at first rehire check.
  • Data has become inconsistent because of multiple onboarding initiations for the same candidate data without proper cancellation.
  • The are two mapping rows of two different version of the same BPE process definition. This is causing the problem when the event is received, BPE engine triggers two process instances with different version of definition.

Resolution

For Live Customers and Implementation Partners

  1. Create a support ticket to check the logs in the backend and confirm that below error is found:
    • No data was found from RCM for application id : UVXYZ, candidate id : XXXXX, job req id : XXXX
    • Applicant is already hired for Application ID: UVXYZ
  2. Provide customer approval for script execution to correct the bad data (delete the older version of the process definition)

    Four Cloud Product Support

    1. Check the logs in the backend
    2. Once confirmed the same error as above, get the Process Instance Id for the affected user/candidate.
    3. Go to BPE: Manage User Tasks and confirm if the affected Process Id is available.
    4. If available, provide the Process Instance Id to the partner/customer and ask to complete the task in BPE: Manage User Task.
    5. If not, raise a service request for script execution.
    6. Once the script has been executed, check and confirm that the verification tile can be opened without any errors.

    See internal note for the sample script request.

    Keywords

    Rehire, Rehire Verification Tile, Tile, Applicant is already hired for Application ID, Onboarding 2.0, OBX, ONB 2.0, INC1115861, INC1967224 , KBA , LOD-SF-OBX-RHM , Rehire Mechanism , Problem

    Product

    SAP SuccessFactors Onboarding 2105