Symptom
- After login to SAC the data load e.g. Recent stories/files etc. to Home page or loading the list of Stories/Models etc. in My Files takes approx. a minute or more.
- This is experienced in every navigation action like selecting a file etc.
- In the HAR file you will that the below request takes the most time:
https://browsernotification-sac-saceu10.cfapps.eu10.hana.ondemand.com/browser-notification/852/vsdx3ru2/websocket
Environment
- SAP Analytics Cloud (Enterprise)
Reproducing the Issue
- Login to SAC.
- Data load e.g. Recent stories/files etc. to Home page or loading the list of Stories/Models etc. in My Files takes approx. a minute or more.
Cause
- The performance issue is caused by the notifications available under the notification panel.
- For reach "Progress" type job that is part of the notifications panel, a single backend request is made to retrieve job status and update notifications panel.
- Since multiple requests made to the Content Manager service were sent individually, this caused proceeding requests made by SAC to be stalled.
Resolution
- Workaround: Clearing the notifications from the notifications panel adjusting the performance in SAC.
- In particular, only the "Progress" type notifications are required to be deleted to resolve this issue
- Resolution: A fix has been deployed to all QRC tenants as of February 2022 to batch all Content Manager requests made by SAC, into one, resolving the issue.
See Also
- 2569847 - Where can you find SAC user assistance (help) to use, configure, and operate it more effectively?
- Have a question? Ask it here and let our amazing SAP community help! Or reply and share your knowledge!
- 2487011 - What information do I need to provide when opening an case for SAP Analytics Cloud?
- 2511489 - Troubleshooting performance issues in SAP Analytics Cloud
- Search for SAP Analytics Cloud content using Google or Bing:
- https://www.google.ca/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- https://www.bing.com/search?q=site%3Ahttps%3A%2F%2Fapps.support.sap.com+SAP+Analytics+Cloud
- Note: Add relevant text or warning/error messages to the text search field to filter results.
- SAP Analytics Cloud Connection Guide
- Getting Started with SAP Analytics Cloud Expert Community page
- SAP Analytics Cloud Get More Help and SAP Support
- Need More Help? Contact Support or visit the solution finder today!
Your feedback is important to help us improve our knowledge base.
Keywords
SAP Cloud for Planning, sc4p, c4p, cforp, cloudforplanning, Cloud for Analytics, Cloud4Analytics, CloudforAnalytics, Cloud 4 Planning, BOC, SAPBusinessObjectsCloud, BusinessObjectsCloud, BOBJcloud, BOCloud., SAC, SAP AC, Cloud-Analytics, CloudAnalytics, SAPCloudAnalytics,Error, Issue, System, Data, User, Unable, Access, Connection, Sac, Connector, Live, Acquisition, Up, Set, setup, Model, BW, Connect, Story, Tenant, Import, Failed, Using, Working, SAML, SSO, sapanalyticscloud, sap analytical cloud, sap analytical cloud, SAC, sap analyst cloud, connected, failure, stopped , KBA , LOD-ANA-ADM , SAC Administration , Problem