Symptom
When opening Manage My Timesheet application, the user receives 'Internal Error'.
Environment
SAP S/4HANA Cloud
Reproducing the Issue
- Open Manage My Timesheet application.
- Error message "Internal Error" is raised and application is not loaded.
Cause
The affected user has multiple employment entries for same period. Overlapping which is leading to exception (Internal error).
You can view the employment for the PERSONWORKAGREEMENT in the CDS View I_PERSONWORKAGRMTSTATUS.
Resolution
Correct the employment information of the affected user.
Keywords
Internal Error , Manage My Timesheet, CA-TS-S4 , KBA , CA-TS-S4 , Cross Application Timesheet in S/4HANA , Problem
Product
SAP S/4HANA Cloud Public Edition all versions ; SAP S/4HANA Cloud all versions