SAP Knowledge Base Article - Public

3112070 - Workflow Rule Does Not Create E-Mail Activity On Object

Symptom

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Workflow Rule E-Mails do not automatically create E-Mail activities on the BO they were sent out for.

Environment

SAP Cloud for Customer core applications

Reproducing the Issue

The issue can be reproducible on any BO, here we will take Service Ticket BO as an example.

  1. Go to the Service work center.
  2. Select to the Tickets view.
  3. Open the Ticket ABC (ABC represents the Ticket ID).
  4. Select the Interactions facet.

In the Interactions, the E-Mail sent from the workflow rule is not displayed.

Cause

The object ID is not set as placeholder in the subject AND / OR the indicator: Create E-Mail Activity was not set.

Resolution

  1. Include the object ID placeholder in the e-mail subject of the workflow rule e-mail. 
  2. Check the 'Create E-Mail Activity' indicator in the workflow rule. 

CreateEMailActivity.png

See Also

KBA 2534062 - E-mail Sent Via Workflow Rule Does Not Show Up In Ticket Interactions

Keywords

Missing, E-Mail, Email, indicator, activity, workflow, BO, facet , KBA , LOD-CRM-WKF , Workflow , How To

Product

SAP Cloud for Customer core applications all versions