Symptom
When the External to Internal Candidate Conversion job runs, it fails with the message: "external candidate already has converted internal profile".
Environment
SAP SuccessFactors Recruiting Management
Cause
The causes we've identified so far are:
- The user that is supposed to be associated with the candidate you wish to convert, is already connected to another candidate profile.
- The criteria in use in Manage Recruiting Settings to identify the candidate to be converted is already used by an existing user. E.g.: the criteria is email. The email of the external candidate is already associated to another existing user in the User Data File in the defined criteria.
Resolution
To fix the issue,
- For Cause 1: It will be required to create a new user, as explained in the KBA 2081409 - Candidate to Employee Conversion - Recruiting Management, the system will only try to convert candidates with that don't have an employee profile associated to another candidate profile. Hence, a new user should be created.
- For Cause 2: It will be required to update the value used in the User Data File so that the criteria matches.
See Also
Keywords
candidate, profile, conversion, employee, user, data, file, export, manage, recruiting, settings, udf, email, id, internal, external. , KBA , LOD-SF-RCM-CAN , General Candidate Issues (not Offers, not Profiles) , Problem
Product
SAP SuccessFactors Recruiting all versions