Symptom
In a Service Order, the Invoice status is set to "Not Started" instead of "Not Relevant" for Non-Billable items as a result of which the overall status of the service order cannot be set to Completed.
Environment
SAP Business ByDesign
Reproducing the Issue
- Go to Service Orders - Service Order Processing.
- Select the Service Order ABC (ABC represents the Service Order ID).
- Edit and navigate to Services and Spare parts tab.
- Under General sub tab, the Non-Billable is ticked.
- But still the Invoice status is showing Not Started.
Cause
This happens since you selected the non-billable flag before entering the product ID.
Resolution
You need to cancel the existing item and create a new one. When adding the new item, kindly maintain the product ID first, and then select the non-billable flag.
Keywords
Service Order, Line Item, Service ID, Product ID, Non-Billable, Checkbox, Ticked, Marked, Selected, Invoice Status, Incorrect, Unable, Complete, In Process , KBA , SRD-CRM-SEO , Service Orders , How To