Symptom
- Employee Central Environment
- Change Engine rules have been defined to Keep the forms with the old Manager and/or Matrix Manager.
- The Manager is changed in the Employee Profile and/or the Matrix Manager changed in the Job Relationship Block
- The change has an effective date of the current or past date
- Following the change, the Employee Change Engine Rules are not applied. Forms are routed to the new Manager/Matrix Manager (Either immediately or when the form is routed)
Environment
- SAP SuccessFactors Performance Management
- SAP SuccessFactors Employee Central
Cause
Change Engine is not triggered if any Manager Transfer Options are enabled. When present/past-dated changes are made in the Employee Profile, the HRIS data is synced using internal mechanisms which have Manager Transfer Options selected, the options are hard-coded and cannot be changed/disabled. Since Manager Transfer Options are selected, Change Engine is not triggered.
Resolution
In order to avoid this issue, the recommendation is to set the change for future date. Future-dated changes are synchronized via the daily HRIS Sync job in provisioning, the Manager Transfer Options can be disabled in the HRIS Synch Job configuration allowing Change Engine to run and keeping the Forms with the Old Manager/Matrix Manager.
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See Also
Keywords
Matrix Manager change engine not working, EX Change Engine, EX transfer, Employee Central, Current date, Manager Transfer, , KBA , LOD-SF-PM-MAP , Routing, Route Maps & Workflows , Product Enhancement