Symptom
Customer is getting the error message "Transaction currency differ from the house bank currency" in the App Post outgoing payments.
Environment
SAP S/4HANA Cloud Public Edition
Reproducing the Issue
- Go to App Post Outgoing Payments.
- Provide the house bank and the house bank account to make the payment posting.
- Simulate the outgoing payment.
Cause
This is a new limitation that is introduce to reflect a correct balance.
Also the transaction currency and the house bank account currency must be identical to post documents.
The currency of the bank account linked to the house bank account differs from the transaction currency.
Resolution
Follow the below steps to resolve the given error message.
- Use the App Manage Bank Accounts.
- Provide the house bank and house bank account number. Note the bank key in the company code.
- Use App Manage Banks to create a new house bank in the same bank key.
- Now go to App Manage bank accounts to create a new bank account with the same account number and the currency = clearing document currency.
- Go to house bank account connectivity assign the new house bank.
- Assign the same house bank account and G/L Account in house bank account data as used in App post outgoing payments .
- Save and activate the bank account.
Now use the new house bank and the same house bank account number to post the payment from the App Post outgoing payment.
See Also
See the to below KBA to understand how the bank account logical key is determined.
3033592 - Bank Account already exists message no. FCLM_BAM_MAINT021 in the App Manage Bank Accounts
Keywords
house, bank, post, outgoing, payment, currency, different, transaction, account, gbp, eur, usd, KR, vendor, FINS_ACDOC_POST094, F1612. , KBA , FIN-FSCM-CLM-BAM , Bank Account Management , FI-FIO-AP , Fiori UI for Accounts Payable , FIN-FSCM-CLM-BAM-2CL , Bank Account Management (Public Cloud) , Problem