SAP Knowledge Base Article - Public

3115405 - Field "Approval Required" is Missing from Sales Quote TI

Symptom

You created a workflow rule to re-submit sales quotes for approval. As condition, you used field "Approval Required" equal to "Yes/No". However, when you try to find this field inside Sales Quote TI, it's missing.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1. You've create a workflow rule ABC (ABC represents rule ID) to re-submit sales quotes to approval. 
  2. As condition, you use field "Approval Required" equals to "Yes/No". Then, you saved and activated the rule. 
  3. Now, you want to check "Approval Required" field on Sales Quote TI, to make sure it's set as "Yes" or "No".
  4. The field is not present on Sales Quote, even in Adaptation Mode. 

Cause

This is the expected behavior.

Resolution

The condition "Approval Required" is only available in the workflow. It is not part of the user interface.

The condition was introduced to configure the re-approval process, being just an attribute of the quote object, not a real field.

See Also

  https://blogs.sap.com/2018/02/27/configure-re-approval-for-sales-quotes-sap-hybris-cloud-for-customer/

Keywords

Sales Quote, Approval Required, Workflow Rule , KBA , LOD-LE-CQP , Customer Quote Processing , How To

Product

SAP Cloud for Customer core applications 2111