SAP Knowledge Base Article - Public

3115465 - Extension Field Not Visible For a Specific Business Role

Symptom

You have an extension field (KUT) which is not visible for users from a specific business role. 
This same field is visible at master layout/page layout.

"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."

Environment

Cloud for Customer

Cause

If the field is visible in the layout (master or page layout in adaptation) it could be made hidden by a business role restriction.

Resolution

  1. Go to Administrator workcenter.
  2. Go to General Settings View.
  3. Click at Business Roles.
  4. Open the affected business role and click view all.
  5. Go to Fields & Actions tab. 
  6. Check the Extension Field Restrictions section.
    KUT_Hidden.png
  7. Change the access restriction of the affected field.
  8. You can choose Read-Only or Unrestricted (depends on your criteria).
  9. Save.

Keywords

field hidden, extension field visibility, not visible , KBA , AP-RC-UIF-FLX , Page Layout & Key User Configuration , How To

Product

SAP Cloud for Customer add-ins all versions ; SAP Cloud for Customer core applications 2102