Symptom
The account was created via data workbench, and later you upload the address information via data workbench 'Account_Addresses' template as well. Then you found the line of address is created as expected, however, there's another blank line of address.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Go to the Customers work centre.
- Go to the Accounts work centre view.
- Search and open Account 123. (123 represents the account ID)
- Go to Addresses facet.
- Here you can see there're 2 lines of address, one is the one you upload via data workbench as expected, another is blank one.
Cause
When you create the account via data workbench, you used the account-header file, and in the account header file, there're a lot of address fields for the default address. You have filled one of the fields thus the system created an instance of node 'AddressInformation'. (For example, you just filled the 'Language' field with value 'EN', and this field belongs to the address. Hence, an 'empty' address instance was created without postal data but only stroring the language).
Then when you upload 'Account_Addresses' in a seperate import the system notices the newly specified address should be the default and creates the new instance.
Resolution
Thus you have to either keep all the address fields empty when uploading the header-csv or
specify the default-address completely in the header-csv and use the separate file only for additional addresses.
Please note the behavior is different for Individual Customers, because the field Language is NOT stored in the
address-node in backend but in node "common" for Individual Customer. This is because for persons there is typically only one language and for organizations the language can vary for different addresses.
Keywords
account, address, data workbench, odata, blank, line, Customer, , KBA , LOD-CRM-ACC , Account , Problem