Symptom
You notice that, for your Installed Base, under Items tab, Item Details section and General Data sub-tab, the standard Product field is added via the Adaptation Mode, however, it is not displayed.
Environment
SAP Cloud for Customer
Reproducing the Issue
- Navigate to Installed Base work center.
- Navigate to Installed Base work center view.
- Search and Open your Installed Base.
- In the Items tab, scroll down until you find the Items section.
- Click on the User Options.
- Click on Start Adaptation.
- Click to Adapt the General Data tab, under Item Details section.
- Try to add the Product field.
- See it is added, but it is not displayed on the UI.
Cause
The Product field will only be visible once the Name column is visible in the UI as well, since the system has a calculation rule which is triggered and which sets the visibility properties of Product Field, based on the Name column.
Resolution
In order to make this column visible, you may follow the steps below:
- Navigate to Installed Base work center view.
- Open any Installed Base.
- In the Items tab, scroll down until you find the Items section.
- Click on the User Options.
- Click on Start Adaptation.
- Make the Name Column visible.
Once this is done, end the adaptation and now you should be able to see Product and other registered product related details in the Item Details Section.
Keywords
Installed Base, Item, Item Details, Section, Sub-Tab, Product, Field, Product Field, Column, Name, C4C, Service, General Data, , KBA , LOD-LE-IBA , Installed Base Data Management , How To