SAP Knowledge Base Article - Public

3117577 - Check Box in Ticket List View is staying checked after refresh

Symptom

In the Tickets List View, when a user un-check's a checkbox and refreshes the screen, the checkbox is checked again.

Environment

SAP Cloud for Customer

Reproducing the Issue

  1.  Go to the Service work centre --> Tickets view
  2. Select any ticket and add a tick mark in the checkbox
  3. Deselect the tick mark in the checkbox
  4. Click Refresh (Not on the browser but the C4C system refresh button)

The checkbox is marked again.

Cause

When you select a checkbox, there is a round trip triggered where a parameter is sent for the Ticket selection. In the backend, there is a variable populated to remember the selection. When you uncheck the checkbox, there is no round trip triggered. Therefore the variable is not cleared and when you hit the refresh it remembers the selection.

Resolution

This is expected behavior.

Keywords

Ticket, checkbox, Refresh, C4C, , KBA , AP-RC-UIF , C4C UI Framework , Problem

Product

SAP Cloud for Customer core applications 2108