Symptom
On the customer level you have replaced manager A for manager B, where A represents the previous manager and B represents the new manager. All customers which were managed by manager A have to be managed by manager B now. Manager B should see the opportunities, contracts, visits etc. which were previously created by manager A. You notice that when manager B logs in to the system, he cannot see the activities created by manager A.
Environment
SAP Cloud for Customer
Reproducing the Issue
1. Go to the Organizational Management work center
2. Go to the Org Structures sub view
3. Find manager B
4. Go to the Employees tab
5. You can see that manager A was replaced by manager B
1. As manager B, go to the Customers work center
2. Go to the Accounts sub view
3. Find a corresponding Account ID
4. Go to the tab Account Team
What you can see as manager B are customers that used to belong to manager A but he cannot see the visits, opportunities, contracts etc, which were created by manager A.
Cause
This is the result of document's access and user's authorization under Administrator -> Check User's Authorization. There is no automatic update of user authorizations if you change the org model. There are batch jobs to recalculate the authorizations, but if you want to have immediate effect, then you have to go to Administrator->Business Users and update the authorizations of the specific user.
Resolution
If user B becomes the manager of the org unit, then he can see the opportunities of the employees of this org unit. But if A is NOT an employee of the org unit any longer (since he left the company), then user B will not see the opportunities/visits of user A.
Solution: migrate the documents/opportunities etc. to another user or keep user A assigned.
Keywords
employee of the Org unit; User Authorization; document access; not see the Visits, Opportunities, Contracts , KBA , LOD-LE-OPP , Opportunity processing , Problem