SAP Knowledge Base Article - Public

3119072 - [Onboarding] Duplicate Emergency Contact records are created when Onboarding process is restarted

Symptom

When the candidate is initiated from Recruiting, one record of primary emergency contact is created. Once I click restart Onboarding, additional primary emergency contact record is created. This process is recurring every time I restart the Onboarding Process.

Environment

SAP SuccessFactors Onboarding

Reproducing the Issue

1. Go to Onboarding dashboard
2. Find any user
3. Click "View Details"
4. Click "Actions" > "Restart Onboarding"

5. Find the same user again in Onboarding Dashboard
6. Check Primary Emergency Contact by click "Action" > "New Recruit Data". Additional record of primary emergency contact is created.

Cause

  • We are aware of this issue and this is a known limitation in the product. 
  • However, the is no planned fix for the same.

Resolution

  • EC has no unique field on their side for Emergency contact so even with all data as same, they don't handle Duplicate entry in HRIS save.
  • Additionally, we can not update / exclude any records as we don't have any field / combination of fields to check unique record.
  • Please delete the record to proceed.

Keywords

Emergency Contacts, Duplicate Record, New Hire Data Review, Restart Onboarding , KBA , LOD-SF-OBX-EC , Integration EC - MPH, Hire , Problem

Product

SAP SuccessFactors Onboarding 2111