SAP Knowledge Base Article - Public

3120535 - When attempting to add multiple contacts to the Lead Contact facet, an error occurs. ''Please use not more than 1 contact(s) for role Account''

Symptom

When you add more than one contact in Lead, you will receive an error message, but you will still be able to save.

Environment

SAP Cloud for Customer.

Reproducing the Issue

  1. Go to the Sales Work Center.
  2. Go to the Leads View.
  3. Search and open lead ID: ABC (ABC stands for the lead ID).
  4. Go to the Contact tab.
  5. Add more than one contact.
  6. Observe: ''Please use not more than 1 contact(s) for role Account''

Cause

In the Business Configuration activity Maintain Involved Parties, you have selected the Contact of Account as Unique. This means that the lead can only have one contact.

Resolution

  1. Go to the Business Configuration work center.
  2. Go to the Implementation Projects view.
  3. Select the relevant project and choose Open Activity List button.
  4. Search and open Leads.
  5. Open Maintain Involved Parties.
  6. In the next screen  find the entry Contact of Account for which you have checked the Unique option.
  7. You need to un-check the Unique option.
  8. Save.

Keywords

unique, leads, Involved parties, Contact of Account , KBA , LOD-CRM-LM , Lead Management , Problem

Product

SAP Cloud for Customer add-ins all versions