SAP Knowledge Base Article - Public

3121080 - Changes on a Segmentation Profile Are Not Applied to the Personalization Attributes List on Email Content

Symptom

After adding a new field, changing the section of an existing field or any other change to the attributes on a segmentation profile, you open an email content on Content Studio app and notice that even after selecting the corresponding segmentation profile for the Personalization Attributes list, the list is not synchronized to the latest changes.

Environment

SAP Marketing Cloud

Cause

The personalization attributes cache is not up-to-date with the latest changes. The cache usually takes about 24 hours to be automatically cleared.

Resolution

It is possible to manually trigger a cache clean up which will force the system to fetch the attributes again from the Segmentation Profile:

  1. Open the affected Email content on the Content Studio app.
  2. Click on Edit.
  3. Select an existing personalized attribute or click on Insert Attribute to add a new one.
  4. Now on the Personalization Attributes list, click on the Gear Icon.
  5. Make any change and click on the Gear Icon again to save the change.
  6. After that, reload the page (F5) and the list will be up-to-date with the latest segmentation profile changes.

The screenshot below show the location of the Gear Icon:

Keywords

personalization attributes, email content, custom fields, segmentation profile, personalization cache , KBA , CEC-MKT-MEM , Content Studio: E-Mails and other messages , CEC-MKT-SEG , Segmentation , Problem

Product

SAP S/4HANA Cloud 2111