Symptom
When customer try to come from BizX to Onboarding 1.0, we might see a ‘seamless login failed’ error. This could happen due to SHA-256 certificate update
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Environment
SAP Successfactors Onboarding 1.0
Reproducing the Issue
- Login to Instance
- Access Onboarding 1.0 dropdown from Bizx
- View Error "Your Seamless login has failed"
Cause
- With our Second Half 2021 Release the SHA-1 signing mechanism in the Assertion Consumer Services (ACS) will be deprecated in favor of the SHA-256 signing certificate.
This is being done as part of our ongoing effort to enhance security. - Update provided in Community Portal
Resolution
What needs to be checked & updated:
- Go to Account’s Provisioning Site
- Authorized SP Assertion Consumer Service Settings page.
- Please verify whether the ‘SHA-256 Certificate’ checkbox is checked or not. If it’s unchecked, please check this checkbox and save it.
- Also go to Admin Centre
- Authorized SP Assertion Consumer Service Settings and make sure SHA-256 Certificate option is checked against Onboarding 1.0
- Then come to Super Admin site and go to the specific account
- Account Options
- Please look for ‘Security.SAML20.X509Certificate.SerialNumber
- Now update this account option with right serial number 494BBDA4
See Also
Keywords
SHA-256 Certificate, Onboarding 1.0, Seamless Error, ERROR [AccountName] [] [] [] KMS.XpressHR.SSO.SAML20.AssertionConsumerService - Certificate serial# [494BBDA4] does not match [XXXX] , KBA , LOD-SF-OBD-INT , Integrations with Onboarding , Problem
Product
Attachments
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