Symptom
- AskHR not working in Mobile App while it is working fine in browser and desktop.
- The error received is "Failed to load data. Please try again later"
"Image/data in this KBA is from SAP internal systems, sample data, or demo systems. Any resemblance to real data is purely coincidental."
Environment
- SAP SuccessFactors HCM Suite
- Employee Central Service Center
- AskHR mobile
Reproducing the Issue
This is reproducible on both iOS and Android device.
1. Login to SF on a mobile app
2. Click on ASKHR link in app
3. Error appears "Failed to load data. Please try again later."
Sample:
Cause
- Configuration issue
- Wrong URL maintained as Endpoint URL in Security Center -> Destinations
- Incorrect Token URL and/or Recipient added under Security Center -> OAuth Configurations
- Incorrect "issuer" field under Security Center > OAuth Configurations
- Certificate between SuccessFactors and BTP is expired
- The error happens for specific users in the system, the affected user(s) cannot access the application due to missing permissions.
Resolution
Cause number 1 / a) 'Wrong URL maintained as Endpoint URL in Security Center -> Destinations' solution:
- Login to SFSF -> Security Center -> Destination Settings
- Remove .int from Endpoint URL
- Sample screenshot from demo instance attached
- Path for correct URL: Go to SAP Business Technology Platform cockpit -> Subscriptions -> click on javaproxy -> Under Applications URLs take the URL that does not have .int and remove /javaproxy from the end
Use this above URL in:
SuccessFactors -> Security Center -> Destination Settings -> Endpoint URL
Cause number 1 / b) 'Incorrect Token URL and/or Recipient added under Security Center -> OAuth Configurations' solution:
- Login to SFSF -> Security Center -> OAuth Configurations and look for the one named 'ECSCMobileApp' as per the Implementation Guide
- Make sure both the Token URL and Recipient fields match the Token Endpoint value (SAP Business Technology Platform -> Security -> OAuth -> Branding -> OAuth URLs)
- Sample screenshot from demo instance attached
Use this above URL in:
SuccessFactors -> Security Center -> OAuth Configurations -> 'ECSCMobileApp' -> Token URL and Recipient
Cause number 1 / c) Incorrect "issuer" field under Security Center > OAuth Configurations:
- Make sure the "issuer" field is set to "servicecenter".
Cause number 1 / d) Certificate between SuccessFactors and BTP is expired:
- Regenerate the certificate under SuccessFactors > Security Center > X509 Certificates > servicecenter (refer to Generating OAuth X509 Key in SAP SuccessFactors);
- Paste it under BTP > Security Trust > Application Identity Provider > servicecenter (refer to Creating Trusted Identity Provider in SAP Business Technology Platform Cockpit);
Cause number 2 'The error happens for specific users in the system, the affected user(s) cannot access the application due to missing permissions' solution:
Please make sure all the permissions mentioned in the official handbook has been granted to the users accessing AskHR.
Role-Based Permissions for Employee Central Service Center
For full list of permissions, please search for 'service center' and 'askhr' in the below guide:
List of Role-Based Permissions
See Also
Other common configuration issues / deviation from the Implementation Guide can cause the error.
Please review your configurations with your Implementation Partner before reporting an issue to Product Support.
Keywords
AskHR, mobile login, error, failed to load data, please try again later, mobile users, service center. , KBA , LOD-SF-INT-AHR , Ask HR - Employee Central Service Center (ECSC) , LOD-SF-INT , Integrations , Problem
Product
Attachments
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